1С Режим Конфигуратор



         

Создание, удаление и корректировка счетов


Обычно счета создаются вручную в режиме Конфигуратор или Предприятие. Но иногда может потребоваться программная корректировка списка счетов.

Счета = СоздатьОбъект("Счет.Основной");

Счета.Новый(1); //у счета будут субсчета

Счета.Код = "10";

Счета.Наименование = "Материалы";

Счета.Активный = 1; //активный

Счета.Записать();

Счета.Новый();

Счета.Код = "10.1";

Счета.Наименование = "Основные материалы";

Счета.ВидСубконто(1,ВидыСубконто.Материалы);

Счета.ВидСубконто(2,ВидыСубконто.Склады);

Счета.Записать();

Пример, изменить наименование счета:

Счета = СоздатьОбъект("Счет.Основной");

Счета.НайтиПоКоду("10");

Счета.Наименование = "Все материалы";

Счета.Записать();

Пример, пометить на удаление все счета, введенные пользователем в режиме "Предприятие". Оставить только счета, заданные разработчиком в Конфигураторе.

Счета = СоздатьОбъект("Счет.Основной");

Счета.ВыбратьСчета();

Пока Счета.ПолучитьСчет()=1 Цикл

.....Если Счета.ЗаданВКонфигурации()=0 Тогда

.........Счета.Удалить(0); //пометить на удаление

.....КонецЕсли;

КонецЦикла;

Пример, отменить все пометки на удаление:

Счета = СоздатьОбъект("Счет.Основной");

Счета.ВыбратьСчета();

Пока Счета.ПолучитьСчет()=1 Цикл

.....Если Счета.ПометкаУдаления()=1 Тогда

.........Счета.СнятьПометкуУдаления();

.....КонецЕсли;

КонецЦикла;




Содержание  Назад  Вперед