1С Режим Конфигуратор



         

Простой перебор операций и проводок


Пример, выбрать все операции за период:

Опер = СоздатьОбъект("Операция");

Опер.ВыбратьОперации(НачДата, КонДата); //заданный период

Пока Опер.ПолучитьОперацию()=1 Цикл

Сообщить(Опер.СуммаОперации);

Сообщить(Опер.Содержание);

//организуем перебор проводок текущей операции

//1-й вариант

Опер.ВыбратьПроводки();

Пока Опер.ПолучитьПроводку()=1 Цикл

Сообщить(Опер.Дебет.Счет);

Сообщить(Опер.Кредит.Счет);

Сообщить(Опер.Сумма);

КонецЦикла;

//2-й вариант перебора проводок текущей операции

Для Ном = 1 По Опер.КоличествоПроводок() Цикл

Опер.ПолучитьПроводкуПоНомеру(Ном); //проводка стала текущей

Сообщить(Опер.Дебет.Счет);

Сообщить(Опер.Кредит.Счет);

Сообщить(Опер.Сумма);

КонецЦикла;

КонецЦикла;




Содержание  Назад  Вперед