1С Режим Конфигуратор



         

Описание


ВводНового(ПризнакКопирования, ОбъектКопирования)

Вызывается при создании интерактивном создании нового документа пользователем. Процедура обычно содержит предустановки значений некоторых реквизитов при создании нового документа или операторы управления видом экранной формы. ПризнакКопирования - имя переменной, которую система установит в "0", если введен просто новый документ, и в "1", если документ скопирован (через F9, например). При этом в Переменную ОбъектКопирования будет передан объект, с которого скопировали. Копирование не следует путать с вводом на основании.

Процедура ВводНового(Копирование)

Если ИмяПользователя() <> "Бухгалтер" Тогда

Предупреждение("Вам не позволено создавать этот документ!");

СтатусВозврата(0); Возврат; //Новый документ не будет создан

КонецЕсли;

Если Копирование = 1 Тогда

Возврат;

КонецЕсли;

КонецПроцедуры

ВводНаОсновании(Основание)

Выполняется при вводе нового документа на основании другого. В переменную Основание передается контекст документа-основания, т.е. теперь вы можете обратиться к его реквизитам через эту переменную:

СуммаДоплаты=Основание.СуммаСверху; //Свой реквизит принимает значение реквизита документа-основания.

Помните, что после обработки этой процедуры система не сохранит информацию о том, что новый документ введен на основании другого. Для реализации такой возможности вы должны иметь во вновь создаваемом документе реквизит типа "Документ", куда можно записать ссылку на документ-основание. Лучше сделать её доступной пользователю, чтобы он потом имел возможность выбрать другой документ-основание.

ПриЗаписи()

Выполняется при записи (перезаписи) документа. Имейте ввиду, что операторы этой процедуры выполняются ДО фактической записи документа в базу. Это, так сказать, подготовительная работа.

ПриВводеСтроки()

Вызывается при вводе пользователем новой стоки многострочной части документа. Такой операцией, например, можно отменить ввод новых строк, если в документе нельзя вводить строки вручную (можно добавить какое-либо условие):




Содержание  Назад  Вперед