1С Режим Конфигуратор



         

Дополнение - часть 8


        Регистр.ОстаткиТоваров.Количество = КолВыб;

        Регистр.ОстаткиТоваров.СуммаП = Окр(ЦенаПП*КолВыб,2,1);

        Регистр.ОстаткиТоваров.СуммаД = Окр(Цена*КолВыб,2,1);

        Регистр.ОстаткиТоваров.ФлагДвижения = 1;

        Регистр.ОстаткиТоваров.ПривязыватьСтроку(НомерСтроки);

        Регистр.ОстаткиТоваров.ДвижениеРасходВыполнить();

        Регистр.ОборотыТоваров.Склад = Склад;

        Регистр.ОборотыТоваров.Товар = Товар;

        Регистр.ОборотыТоваров.Сорт = Сорт;

        Регистр.ОборотыТоваров.Количество = КолВыб;

        Регистр.ОборотыТоваров.СуммаУ = Окр(ЦенаПП*КолВыб,2,1);

        Регистр.ОборотыТоваров.ФлагДвижения = 1;

        Регистр.ОборотыТоваров.ПривязыватьСтроку(НомерСтроки);

        Регистр.ОборотыТоваров.ДвижениеВыполнить();

        КолВыб=КолВыб-Ост;

      КонецЕсли;

    КонецЕсли;

  КонецЦикла;

  ТабЗн2.УдалитьСтроки();

// удаляем строки из временной таблицы.

// Готовим ее под следующую строку документа

КонецЦикла;

Здесь мы воспользовались для определения партий механизмом прямой выгрузки данных из регистра в таблицу значений.

  • Теперь опишем методику списания по LIFO. Мы, конечно можем, воспользоваться предыдущим примером, заменив строку

          ТабЗн2.Сортировать("1+",1);

    На  ТабЗн2.Сортировать("1-",1);

          // Сортировка документов по убывающей. Последний – сверху

    Но мы легких путей не ищем! Воспользуемся механизмом запроса.

  • Заместо строки "// Здесь будет записана методика списания по LIFO" напишем:

    // Здесь будет записана методика списания по LIFO

    ВыбратьСтроки();

    Пока ПолучитьСтроку()=1 Цикл

      КолСпис=КолО;




    Содержание  Назад  Вперед