1С Режим Конфигуратор



Дополнение - часть 4


    Возврат;

  КонецЕсли;

  Если Сборщик.Выбран()=0 Тогда

    Сообщить("Документ Наряд на сборку №"+НомерДок+"

    |от "+ДатаДок+" не проведен.

    |Не указан сборщик");

    НеПроводитьДокумент();

    Возврат;

  КонецЕсли;

// Это были обычные проверки

  ТабЗн=СоздатьОбъект("ТаблицаЗначений");

  ТабЗн.НоваяКолонка("Ком","Справочник.Комплектующие");

  ТабЗн.НоваяКолонка("Кол","Число",12,0);

  СпрКом=СоздатьОбъект("Справочник.Комплектация");

  ВыбратьСтроки();

  Пока ПолучитьСтроку()=1 Цикл

    СпрКом.ИспользоватьВладельца(Изделие);

    СпрКом.ВыбратьЭлементы();

    Пока СпрКом.ПолучитьЭлемент()=1 Цикл

      ТабЗн.НоваяСтрока();

      ТабЗн.Ком=СпрКом.ТекущийЭлемент().Комплектующее;

      ТабЗн.Кол=Кол;

    КонецЦикла;

    СпрКом.ИспользоватьВладельца("");

  КонецЦикла;

  БухИтоги=СоздатьОбъект("БухгалтерскиеИтоги");

  БухИтоги.ИспользоватьПланСчетов(ПланыСчетов.Наш);

  БухИтоги.ИспользоватьРазделительУчета(ФирмаДокумента);

  ФлагОтказа=0;

  ТабЗн.Свернуть("1","2");

  ТабЗн.ВыбратьСтроки();

  Пока ТабЗн.ПолучитьСтроку()=1 Цикл

    Ком=ТабЗн.Ком;

    Колич=ТабЗн.Кол;

    БухИтоги.ИспользоватьСубконто(ВидыСубконто.МестоХранения,Склад,2);

    БухИтоги.ИспользоватьСубконто(ВидыСубконто.Комплектующее,Ком,2);

    БухИтоги.ВыполнитьЗапрос(,ДатаДок,"10.2");

    КолКом=БухИтоги.СКД(3);

    Если Колич>КолКом Тогда

      ФлагОтказа=1;

      Сообщить(Строка(Ком));

    КонецЕсли;

  КонецЦикла;

// Если посмотреть модуль документа, это похоже на процедуру Заявка()




Содержание  Назад  Вперед