1С Режим Конфигуратор



Дополнение - часть 4


  ВыбСтрока=1;

  Если ТабЗн2.ВыбратьСтроку(ВыбСтрока,

      СокрЛП(ВыбТов.Код)+" ("

      +СокрЛП(ВыбТов.Наименование)+")")=1 Тогда

// Выберем строку с нужным сортом

    НоваяСтрока();

// создаем в документе новую строку

    Товар=ВыбТов;

// заполняем поле "Товар"

    СортВыб=ТабЗн2.ПолучитьЗначение(ВыбСтрока,"Сорт");

// по выбранной строке получаем сорт

    КолОст=ТабЗн2.ПолучитьЗначение(ВыбСтрока,"Остаток");

// и остаток

    Сорт=СортВыб;

    СпрЕд=СоздатьОбъект("Справочник.Единицы");

    СпрЕд.ИспользоватьВладельца(Товар);

    СпрЕд.ВыбратьЭлементы();

    Пока СпрЕд.ПолучитьЭлемент()=1 Цикл

      Если СпрЕд.Ед=Товар.ЕдИзм Тогда

        Ед=СпрЕд.ТекущийЭлемент();

        Прервать;

      КонецЕсли;

    КонецЦикла;

// это уже было...

    Цена=Окр(Товар.ЦенаР.Получить(ДатаДок)*(Сорт.Процент/100),2,1);

    КолВыб=0;

    Если ВвестиЧисло(КолВыб,СокрЛП(ВыбТов.Код)

        +"/"+СокрЛП(Строка(СортВыб)+" кол:"

        +Строка(КолОст)),8,2,0)=1 Тогда

// Введем нужное нам количество

      Если КолВыб>КолОст Тогда

// сравним введенное нами количество с остатком

        КолВыб=КолОст;

      КонецЕсли;

      Кол=КолВыб;

      КолО=Окр(Кол*(Ед.Коэффициент),2,1);

      Сумма=Окр(КолО*Цена,2,1);

    КонецЕсли;

    АктивизироватьСтроку();

// установим курсор в документе на строку, которую мы ввели

  КонецЕсли;

КонецПроцедуры

  • Перейдем теперь к написанию модуля проведения документа;
  • Напишем в модуль документа следующее:

    Процедура ОбработкаПроведения()

      РегОст=СоздатьОбъект("Регистр.ОстаткиТоваров");




    Содержание  Назад  Вперед