1С Режим Конфигуратор



Дополнение - часть 3


      |РегТовар=Регистр.ОстаткиТоваров.Товар;

      |РегСорт=Регистр.ОстаткиТоваров.Сорт;

      |РегПартия=Регистр.ОстаткиТоваров.Партия;

      |РегКолич=Регистр.ОстаткиТоваров.Количество;

      |РегСумма=Регистр.ОстаткиТоваров.СуммаП;

      |Группировка РегПартия Упорядочить по РегПартия.ДатаДок;

      |Функция КолКонОст=КонОст(РегКолич);

      |Функция СумКонОст=КонОст(РегСумма);

      |Условие (РегСклад=СкладО);

      |Условие (РегТовар=Товар);

      |Условие (РегСорт=Сорт);";

      Запрос=СоздатьОбъект("Запрос");

      Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда

        Сообщить("Документ не проведен");

        НеПроводитьДокумент();

        Возврат;

      КонецЕсли;

      Пока Запрос.Группировка("РегПартия",1)=1 Цикл

// Сортируем группировку по возрастанию

        Если КолСпис=0 Тогда

          Прервать;

        КонецЕсли;

        ПартияСписания=Запрос.РегПартия;

        Если  Запрос.КолКонОст>КолСпис Тогда

          Списывать=КолСпис;

          Стоимость=Окр((Запрос.СумКонОст/Запрос.КолКонОст)

          *Списывать,2,1);

        ИначеЕсли Запрос.КолКонОст=КолСпис Тогда

          Списывать=КолСпис;

          Стоимость=Запрос.СумКонОст;

        ИначеЕсли Запрос.КолКонОст<КолСпис Тогдаbr>           Списывать=Запрос.КолКонОст;

          Стоимость=Запрос.СумКонОст;

        КонецЕсли;




Содержание  Назад  Вперед