1С Режим Конфигуратор



Дополнение - часть 2


    Пока СпрКом.ПолучитьЭлемент()=1 Цикл

      ТабЗн.НоваяСтрока();

      ТабЗн.Ком=СпрКом.ТекущийЭлемент().Комплектующее;

// Это мы определили, что входит в комплект

      ТабЗн.Кол=Кол;

// И сколько

    КонецЦикла;

    СпрКом.ИспользоватьВладельца("");

  КонецЦикла;

  СпрКом="";

  Таб=СоздатьОбъект("Таблица");

  Таб.ИсходнаяТаблица("");

  Таб.ВывестиСекцию("Шапка");

  ТабЗн.Свернуть("1","2");

// Суммируем строки с одинаковыми комплектующими

  ТабЗн.Сортировать("1");

  ТабЗн.ВыбратьСтроки();

  Стр=1;

  Пока ТабЗн.ПолучитьСтроку()=1 Цикл

    Комп=ТабЗн.Ком;

    НазвРодителя=СокрЛП(Комп.Родитель.Наименование);

    Поз1=Найти(НазвРодителя,"(");

    Поз2=Найти(НазвРодителя,")");

    ГОСТ=Сред(НазвРодителя,Поз1+1,Поз2-Поз1-1);

    Ком=СокрЛП(Комп.Наименование)+" "+ГОСТ;

    Колич=ТабЗн.Кол;

    Таб.ВывестиСекцию("Строка");

    Стр=Стр+1;

  КонецЦикла;

  Таб.ТолькоПросмотр(1);

  Таб.ПараметрыСтраницы(1,100,1);

  Таб.Показать("");

КонецПроцедуры

//==========================================================

Функция Ост(Скл,Изд)

// Функция с двумя параметрами на входе: Склад и Изделие

  СпЗн=СоздатьОбъект("СписокЗначений");

  СпрКом=СоздатьОбъект("Справочник.Комплектация");

  БухИтоги=СоздатьОбъект("БухгалтерскиеИтоги");

  БухИтоги.ИспользоватьПланСчетов(ПланыСчетов.Наш);

  БухИтоги.ИспользоватьРазделительУчета(ФирмаДокумента);

  СпрКом.ИспользоватьВладельца(Изд);

  СпрКом.ВыбратьЭлементы();

// Обходим все комплектующие, входящие в изделие

  Пока СпрКом.ПолучитьЭлемент()=1 Цикл

    СКом=СпрКом.ТекущийЭлемент();




Содержание  Назад  Вперед