1С Режим Конфигуратор



Дополнение - часть 2


// копируем содержимое строк

    НоваяСтрока();

    Товар=ДокОсн.Товар;

    Сорт=ДокОсн.Сорт;

    Кол=ДокОсн.Кол;

    Ед=ДокОсн.Ед;

    КолО=ДокОсн.КолО;

    Цена=Товар.ЦенаП.Получить(ДатаДок);

    Сумма=Окр(КолО*Цена,2,1);

  КонецЦикла;

КонецПроцедуры

  • Процедуру проведения пишем по аналогии с расходной накладной:

    Процедура ОбработкаПроведения()

      РегОст=СоздатьОбъект("Регистр.ОстаткиТоваров");

      Если СравнитьТА()=-1 Тогда

        РегОст.ВременныйРасчет(1);

        РассчитатьРегистрыНа(ТекущийДокумент());

      КонецЕсли;

    // Проверка на наличие на остатке

      ВыбратьСтроки();

      ФлагОтказа=0;

      Пока (ПолучитьСтроку()>0) Цикл

        Остат=РегОст.СводныйОстаток(СкладО,Товар,Сорт,,"Количество");

        Если Остат<КолО Тогдаbr>       Сообщить("Нет товара № "+СокрЛП(Товар.Код)+"/"

                  +СокрЛП(Сорт.Наименование)+" в колич. "

                  +КолО+" (имеется "+Остат+")");

          ФлагОтказа=1;

        КонецЕсли;

      КонецЦикла;

      Если ФлагОтказа=1 Тогда

        НеПроводитьДокумент();

        Возврат;

      КонецЕсли;

      Если Константа.МетодСписания=Перечисление.МетодСписания.ФИФО Тогда

    // Здесь будет записана методика списания по FIFO

        ВыбратьСтроки();

        Пока ПолучитьСтроку()=1 Цикл

          КолСпис=КолО;

          Запрос="";

          ТекстЗапроса="";

          Если ИтогиАктуальны()=0 Тогда

            ТекстЗапроса="

            |Период с ДатаДок по ДатаДок;";

          КонецЕсли;

          ТекстЗапроса=ТекстЗапроса+"

          |РегСклад=Регистр.ОстаткиТоваров.Склад;




    Содержание  Назад  Вперед