1С Режим Конфигуратор



Дополнение - часть 2


// выбранному товару

    СпрЕд.ВыбратьЭлементы();

    Пока СпрЕд.ПолучитьЭлемент()=1 Цикл

// перебираем справочник единиц поэлементно

      Если СпрЕд.Ед=Товар.ЕдИзм Тогда

// мы нашли единицу соответствующую основной единице товара

        Ед=СпрЕд.ТекущийЭлемент();

// передаем в реквизит табличной части найденное значение

        Прервать;

// прерываем обход по циклу. То, что мы искали уже найдено

      КонецЕсли;

    КонецЦикла;

    КолО=Окр(Кол*(Ед.Коэффициент),2,1);

// пересчитываем количество в количество основных единиц

    Цена=Окр(Товар.ЦенаП.Получить(ДатаДок)*(Сорт.Процент/100),2,1);

// определяем цену товара с учетом текущего сорта

    Сумма=Окр(КолО*Цена,2,1);

// вычисляем сумму

  КонецЕсли;

КонецПроцедуры

  • Теперь нам надо по выбору сорта менять цену и соответственно сумму. В свойствах колонки "Сорт" на закладке "Дополнительно" напишем формулу Сорт();
  • В модуль формы добавляем процедуру:

    Процедура Сорт()

      Если Сорт.Выбран()=1 Тогда

        Цена=Окр(Товар.ЦенаП.Получить(ДатаДок)*(Сорт.Процент/100),2,1);

        Сумма=Окр(КолО*Цена,2,1);

      КонецЕсли;

    КонецПроцедуры

  • Теперь нам надо, если изменится значение в колонке "Кол", то менялись бы "КолО" и "Сумма". В свойствах колонки "Кол" на закладке "Дополнительно" напишем формулу Кол();
  • В модуль формы добавляем процедуру:

    Процедура Кол()

      КолО=Окр(Кол*(Ед.Коэффициент),2,1);

      Сумма=Окр(КолО*Цена,2,1);

    КонецПроцедуры

  • Теперь нам надо, если изменим единицу измерения, то пересчитывалось бы "КолО" и "Сумма". В свойствах колонки "Ед" на закладке "Дополнительно" напишем формулу Ед();
  • В модуль формы добавляем процедуру:

    Процедура Ед()

      КолО=Окр(Кол*(Ед.Коэффициент),2,1);

      Сумма=Окр(КолО*Цена,2,1);

    КонецПроцедуры




  • Содержание  Назад  Вперед