1С Режим Конфигуратор


Дополнение - часть 10


      СумП=БухИтоги.СКД(1);

      Если КолКом>0 Тогда

// Заполняем таблицу по комплектующим-партиям

        ТабКом.НоваяСтрока();

        ТабКом.Ком=КомП;

        ТабКом.Док=ДокП;

        ТабКом.Кол=КолП;

        ТабКом.Сум=СумП;

        КолКом=КолКом-КолП;

      Иначе

        Прервать;

// Чтобы не выбирать лишних партий

      КонецЕсли;

    КонецЦикла;

  КонецЦикла;

  ТабЗн.УдалитьСтроки();

  ТабЗн="";

  ТабКом.Сортировать("1+,2+");

  СуммаОпер=0;

  ВыбратьСтроки();

  Пока ПолучитьСтроку()=1 Цикл // По Изделию

    НС=НомерСтроки;

    Изд=Изделие;

    СпрКом.ИспользоватьВладельца(Изделие);

    СпрКом.ВыбратьЭлементы();

    Пока СпрКом.ПолучитьЭлемент()=1 Цикл // По Комплектующей

      Колич=Кол;

      КомТ=СпрКом.ТекущийЭлемент().Комплектующее;

      ТабКом.ВыбратьСтроки();

      Пока ТабКом.ПолучитьСтроку()=1 Цикл // По Партии

// Выбираем партии из динамической таблицы!

        КомП=ТабКом.Ком;

        Если КомП<>КомТ Тогда

          Продолжить;

// Запрашиваемая комплектующая не соответствует строке в таблицу, идем дальше

        КонецЕсли;

        ДокП=ТабКом.Док;

        КолП=ТабКом.Кол;

        Если КолП=0 Тогда

// Партия уже опустошена, пропускаем

          Продолжить;

        КонецЕсли;

        СумП=ТабКом.Сум;

        СтрП=ТабКом.НомерСтроки;

        Если Колич>КолП Тогда

          ПривязыватьСтроку(НС);




Начало  Назад  Вперед